win7上运行PHP和ZendOptimizer

计算机 / , , , / at

WIN7上是基于FASTCGI运行的PHP,今天要测试一个ZEND加密过的PHP程序,所以安装了ZendOptimizer-3.3.3,但怎么都失败,网上搜索了一把,发现是FASTCGI的原因,说WIN7上用ISAPI执行PHP就OK了,按照不用FASTCGI基于IIS给WINDOWS2003配置PHP设置运行后一切正常,希望后面的兄弟少走弯路,WIN7上IIS配置ISAPI运行PHP的关键步骤如下:

1、打开INTERNET信息服务(IIS)管理器,点机器名-IIS-处理程序映射-添加脚本映射
请求路径:*.php
可执行文件:PHP目录下的php5isapi.dll文件位置
名称:php
2、确认后会提出对话框:要允许此ISAPI扩展吗?单击“是”即可。这时IIS – ISAPI和CGI限制 下会出现这个条目。
3、重新启动IIS,这时PHP就能正常运行了
4、按提示步骤安装ZendOptimizer,这个不再赘述。

这里要注意的是,必须下载PHP5.2版本,因为ZendOptimizer是不支持PHP5.3的,还要记住需要下载VC6 x86 Thread Safe版本的PHP,这个里面才有php5isapi.dll,这个是线程安全检查的PHP版本,对于ISAPI方式运行的PHP强烈推荐。如果是FASTCGI版本就推荐下载不用线程安全检查的VC9 x86 Non Thread Safe版本,因为FASTCGI是基于单线程运行的。

2条回应:“win7上运行PHP和ZendOptimizer”

  1. 终于搞定了谢谢。有空再来拜读

  2. dd说道:

    我系统是win7 64位,wamp2.1 就无法安装zend optimizer

发表评论

电子邮件地址不会被公开。 必填项已用*标注